ELA-545-1 aide security update

heap-based buffer overflow

2022-01-24
Packageaide
Version0.16~a2.git20130520-3+deb8u1
Related CVEs CVE-2021-45417


David Bouman discovered a heap-based buffer overflow vulnerability in the base64 functions of aide, an advanced intrusion detection system, which can be triggered via large extended file attributes or ACLs. This may result in denial of service or privilege escalation.



For Debian 8 jessie, these problems have been fixed in version 0.16~a2.git20130520-3+deb8u1.

We recommend that you upgrade your aide packages.

Further information about Extended LTS security advisories can be found at: debian Extended Long term support